博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU sum问题
阅读量:7165 次
发布时间:2019-06-29

本文共 651 字,大约阅读时间需要 2 分钟。

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
代码如下:
#include<stdio.h>
int main()
{   
 int n,m;   
 while(scanf("%d",&n)!=EOF)   
 {       
  if(n%2==0)            
    m=n/2*(n+1);        
  else            
    m=(n+1)/2*n;       
  printf("%d\n\n",sum);  
 }   
 return 0;
}
之前我没考虑奇偶问题,一直过不了。

转载于:https://www.cnblogs.com/wangyouxuan/p/3218001.html

你可能感兴趣的文章